System.Xml.XmlException
System.InvalidOperationException: В документе XML (0, 0) присутствует ошибка. ---> System.Xml.XmlException: Отсутствует корневой элемент.
Решение: удалить конфиг плагина.
Versioned entity was modified before actions execution
Code Block |
---|
Versioned entity Resto.Front.Api.V6.Data.Orders.Order was modified before actions execution. Expected version 0, actual version: *** |
Причины:
...
Работа с приложения, подключенного к плагину не на главной кассе.
Причина: Главный терминал установлен в режим “Не синхронизировать”
...
Отследить ошибку в логе плагина и проверить в этом же логе отсутствие предупреждения о том, что терминал не ГК.
Code Block |
---|
WARN [ 1] - Current iikoFront terminal is not main. Run WaiterServer pligin on the main terminal only. |
Решение: проверить, что на ГК есть плагин iikowaiter и он работает. Проверить, что на ведомых терминалах нет плагина WaiterServer, к которым могли бы подключаться пользователи.
Приложение не подключается к кассе
Одна из причин: У кассы больше одного IP адреса.
Проверка: В логе плагина перечислены все поддерживаемые IP адресы кассы (“Terminal v4 IP addresses” - строка из лога). Подключиться вручную с приложения к кассе по каждому IP пока подключение не установится. Либо, в браузере устройства проверить каждый IP: http://[IP]:8105.
Решение: IP адрес, по которому удалось подключиться прописать в конфиге плагина: QR → Address.
Ошибка при логине в приложении на предприятии в iikoChain
Причина: Одинаковый пин-код у нескольких сотрудников в разных RMS.
Решение: Всем сотрудникам присвоить разные пин-коды. Например, по принципу N****, где N - число для каждого отдельного RMS.
RestaurantSectionItemExtensions
...
Причина: В настройках ресторана используются схемы залов. Одна из схем залов не имеет столов. (Баг iikoFront).
Решение: удалить схему залов без столов. iiko 7.6.7003.0. Если не помогло, то в любом случае что-то со схемой зала. Ошибка возникает на стороне iikoFront.
Как вариант попробуйте следующее:
В списке схем залов скопируйте текущую схему. Она добавится в список как неактивная.
Удалите текущую активную схему зала
Перегрузите фронт и проверьте стартанул ли плагин
...
System.InvalidOperationException: Section for table
...
*** not found.
Code Block |
---|
System.InvalidOperationException: Section for table (Id = GUID, Number = ...) not found. |
Причина: ошибка в api v7, где-то в настройках отделений используется удаленный стол или отделение Баг в Office RMS-53323, приводящий к ошибке в Resto.Front.Api.V7.
Решение:
Обновить
...
Front/Office до 8.0.6 и выше.
...
На БД Front выполнить скрипт ниже чтобы найти удаленный объект. GUID взять из сообщения об ошибке в логе WaiterServer.
Восстановить отделение стола.
Удалить отделение через Office.
Code Block |
---|
SELECT [Id] ,[Type] ,[Xml] FROM [Entities] where xml like '%GUID%' |
...
Template “…“ has scale “…“, therefore product size must be specified.
Для блюд со схемой модификаторов на экране выбора модификаторов не отображается группа с размерами блюда. Воспроизводится на версиях iiko 7.7.7, 7.9.1.
...
Другие способы решения проблем: https://arbus.atlassian.net/wiki/spaces/IIKOWAITER/pages/2457681#%D0%A0%D0%B5%D1%88%D0%B5%D0%BD%D0%B8%D0%B5-%D0%BF%D1%80%D0%BE%D0%B1%D0%BB%D0%B5%D0%BC
Не происходит чекин по штрихкоду
Важно: именно штрихкод, а не QR
За сканирование и распознавание различных кодов отвечает сторонняя библиотека. Проблема на текущий момент затрагивает только коды формата Code-128 (т.е. этот формат не поддерживается iikoWaiter), см также Чекин гостя
С нашей стороны мы обратились за помощью к разработчикам этой библиотеки.
Временных вариантов решения пока несколько:
...
Добавить к отображаемому коду пробел. Получим: "79281145225 " (в конце один пробел). В таком виде код считывается успешно.
...
Некоторые системы лояльности позволяют изменить формат кода. Например, заменить Code-128 на QR code.
...
PaymentActionFailedException: The order was not paid. Cannot perform remote payment
Причина: Если режим обслуживания ресторан и в отделениях выставлена сервисная печать до/после оплаты происходит проблема оплаты заказа через апи фронта.
Решение: В настройках отделения, на котором не закрывается заказ, нужно выставить параметр “автоматическая сервисная печать - отключена”. Проблема исправлена в 8.0.6
Ошибка подключения к POS серверу iikoCard
В веб-админке плагина при выполнении Check connection для Card5 возвращается сообщение об ошибке.
Wrong user name [ ] or password [6***6]
Решение:
Выполнить диагностику POS сервера на предмет установленной последней всерии
Выполнить обновление подключений в списке приложений iiko.biz
Сбросить БД POS сервера
Другие проблемы
Resto.Front.Api.Exceptions.PaymentActionFailedException: There are payment items in the order. Проблема встречается на iiko 7.2.*. Решается обновлением iiko.
Отображаются удалённые столы. Проблема с багом в iikoFront API V6 в iiko 7.3.*. Решается обновлением iiko.
...