Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

Перечень неисправностей

Expand
titleЗаказ не может быть доставлен - за радиусом Х метров

Причины

  1. Курьер действительно находится за прелелами заданного радиуса;

  2. В iikoFront указан неверный адрес доставки;

  3. Смартфон «убивает» фоновый процесс приложения доставки.

Третья причина актуальна у смартфонов от производителей HUAWEI и Xiaomi

Решение

Для причин рекомендуется выполнить описанные ниже действия

  1. Убедиться в том, что курьер не манипулирует Вами, и действительно находится в нужном месте;

  2. Обращаем внимание, что географические координаты адреса доставки определяются автоматически без участия человека. От того, насколько корректно будут внесены город, улица, дом, зависит вероятность возникновения ошибок при доставке заказа и временнЫе потери. Поэтому, процессу набора адреса нужно уделять не меньше внимания, чем качеству готовой продукции и заботе о клиентах. Примеры НЕПРАВИЛЬНЫХ вариантов использования iiko доставки:

Вместо адреса, дополнительные сведения курьеру (уточняющие фразы не относящиеся к адресу) следует писать в поле “Комментарий к заказу” как на рисунке ниже:

Image RemovedImage Added

3. Для корректного определения местоположения курьера приложение должно постоянно поддерживать работу в фоновом режиме. Оболочки смартфонов таких производителей как HUAWEI и Xiaomi по-умолчанию настроены на агрессивное ограничение работы фоновых процессов. Для исправления этой ситуации необходимо вручную разрешить работу приложения доставки в фоновом режиме.

Выполните следующие действия: перейдите в Настройки телефона> Аккумулятор> Запуск приложения, а затем установите для своего приложения «Управление вручную» и убедитесь, что все включено (Phone settings > Battery > App launch and then set your app to “Manage manually”).

info

Инструкция приведена для смартфонов HUAWEI с оболочкой EMUI 9.1. На других смартфонах аналогичные параметы управления энергопотреблением приложений.

Note

При включённом ручном управлении питанием приложения доставки, в некоторых случаях, возможно появление сообщения о повышенном потреблении приложением энергии. Это является нормальной ситуацией и связано с постоянно активным подключением к GPS.

Expand

Связанные статьи

Filter by label (Content by label)
showLabelsfalse
max5
spacescom.atlassian.confluence.content.render.xhtml.model.resource.identifiers.SpaceResourceIdentifier@b926ca0d
showSpacefalse
sortmodified
typepage
reversetrue
labelskb-troubleshooting-article
cqllabel = "kb-troubleshooting-article" and type = "page" and space = "iikoDM"

...